Duplicate emails
Incident Report for EdSmart Platform Status
Resolved
Our Engineering team have deployed a new outbound email module. This redesign has enabled us to fix the two issues causing the duplicate messages - messages being placed in our outbound queue multiple times, as well as our outbound message processing not coping with the volume of messages to send. Now, the duplicate email issue is resolved, and in addition, average times from an email is dropped into the outbound queue, to when it is sent, are a significant improvement on the previous system. We also now can deliver emails faster; better handle and log errors; and scale way beyond our current peak email loads.
Posted 2 months ago. Mar 12, 2019 - 18:30 AEDT
Update
Our engineering team is continuing to work on a fix for the duplicate emails, which will be around transaction handling to ensure messages that have been sent are removed properly from the queue, particularly when the system is under load.
Posted 3 months ago. Feb 12, 2019 - 10:10 AEDT
Identified
While monitoring the results of the fixes we made for duplicate emails last weekend, we are seeing a few duplicate emails being sent for slips and broadcasts, particularly to staff. This is at a much smaller scale than before, and also appears to be related to times of peak load on our database. Engineering's plan is to address our school import processing, which will reduce load, and in parallel, they are working to resolve the bugs related to duplicate emails.
Posted 3 months ago. Feb 08, 2019 - 15:01 AEDT
This incident affected: Application.